Getting back on the road

sdibbers

Well-Known Member
#1
I have just bought my new to me 1969 2000TC and I need to get her back on the road. You can see pics of the car arriving here:
http://www.classicroverforum.net/viewto ... 22&t=19059

The brake system has suffered from its lay up over the last few years. The pedal sinks to just above the floor, there are signs of fluid leaks around the diff. The servos seem to be full of brake fluid so are not great news either. Fortunately I have a spare final drive full set of calipers and servos from my old car. (doesn't everyone?)

I've pulled the rear calipers already and cleaned up the final drive. By heck that's a heavy unit!

I'll paint the diff and De Dion tube and drive shafts with black Rustoleum this weekend after I've wire brushed the lose paint and rust off. I have already spent a fair amount of time removing 45 years worth of gunk from the unit. I replaced the nose oil seal about 6k miles ago and I noticed a small weep from the drive shaft oil seals. I'm not sure if I want to have a go at those as it's pretty minimal.

I'll post some pics later of progress with the rear calipers. They were sleeved with stainless steel a few years ago but the pistons had rusted badly while the old car was stored. Mark Gray has sent me a rebuild kit and stainless steel pistons. Hopefully I will get them before the weekend. If so I might get a chance to get them sorted. Along with that I have some braided hoses and rebuild kits for the front calipers too. I should be in a good place with those fitted to the car.

I rebuilt the servos off my old car a while back. But they were looking a little tatty. So a month or two back I cleaned them up and repainted them. I did a little write up on that here: viewtopic.php?f=21&t=18412

I'll try and be good about taking pics of progress.
 

Attachments

harveyp6

Well-Known Member
#2
sdibbers said:
I noticed a small weep from the drive shaft oil seals. I'm not sure if I want to have a go at those as it's pretty minimal.
The leaks may improve with use, but make sure the breather is clear while the diff is out.
 

sdibbers

Well-Known Member
#4
harveyp6 said:
sdibbers said:
I noticed a small weep from the drive shaft oil seals. I'm not sure if I want to have a go at those as it's pretty minimal.
The leaks may improve with use, but make sure the breather is clear while the diff is out.
That's what I'm hoping Harvey. When the car was on the road it was pretty dry around there. If I recall correctly its a bit of work getting the output shafts out of the way to replace the seals isn't it?
 

harveyp6

Well-Known Member
#5
sdibbers said:
If I recall correctly its a bit of work getting the output shafts out of the way to replace the seals isn't it?
Removing the shaft assemblies isn't a problem, but pressing the collars off and pressing the shaft out of the bearing housing can be. (For some at least, as shown by the current thread running elsewhere on here at the moment).
 

sdibbers

Well-Known Member
#6
I'll check that out and see if it sways me :)
I think I will try plan A for now. If it looks bad after a good few miles (its really not bad now TBH) I will consider pulling and fixing.
 

sdibbers

Well-Known Member
#7
Busy day off today. I've been lucky today as it's a bank holiday weekend here in the US. My company decided to close for today as well as Monday.

Big news is: after two years of sitting in Row's garage she started! Well after a change of fresh oil and coolant. I had to use starter fluid as the fuel is also two years old.

I was able to paint the rear caliper bodies, covers and hand brake quadrant after cleaning them up.
And I've finished cleaning the final drive. I've also split the diff and de Dion tube.
One last thing was this, I've known Row and his car for about 7-8 years. And in all that time there was one thing that really bugged me. It was that the front over riders were too close together. And I've finally got them in the right place!

Ok. Time for me to sign off here. I'll post pics tomorrow when I'm not on the phone.
 
#8
Stephen,

Great to see that Rowland's car will be actively used again and that he remains involved with the car. He was an enthusiastic supporter of a series of Rover meets in New York and Connecticut that pre-dated the larger Rove America events in Massachusetts. I look forward to seeing it at RA -- next year?

Please give Rowland my regards.

Steve Manwell
 

sdibbers

Well-Known Member
#9
As promised a couple of pics from Friday's activities. Saturday I had to be social (it happens that way sometimes :) ) so not much achieved then apart from cleaning up the front calipers. I ordered a rebuild kit for them, but taking a closer look it seems they were rebuilt not so long ago. The rubber looks and feels brand new. So I think a splash of silver rustoleum high temp silver just to keep them pretty and they will go back on the car along with the other parts.

Steve, I will certainly remember you to Rowland. I'm sure he'll be pleased to hear how you are. As I'm sure you remember he's a lovely bloke.

Here's the pics:









I was hoping against hope that the rebuild kits would make it here before the weekend, alas not. Monday is a bank holiday, so with luck I will see them early next week.

As I go through the car I'm finding a few items that will need attention. The tacho isn't registering at the moment, I notice that there's a wire going from the coil straight to the dizzy. I guess the original wire has broken somewhere and needs replacing.

Also the alternator light isn't coming on. With luck it's a bulb, although the alt seems to be charging the battery nicely. I know the alternator charging light box on the wing is known to have issues sometimes and I found a test guide online a little while ago. But with luck it's just the bulb.

The indicators are slow blinking, but all lights are working. Time to go through all the earthing points I suppose.

The car is remarkably rust free apart from some scale in the boot floor caused I guess by water leaks. Hopefully I can wire brush and POR 15 it. If not I might need to fabricate a new floor.

I want to clean off the underside and engine compartment, paint and underseal to preserve its condition. It will also improve how it looks under the bonnet. I think that will be my winter project. I'll enjoy punting around for the summer then address that and some other less pressing matters while the engine is out.
 

Attachments

sdibbers

Well-Known Member
#10
It's been a busy weekend. I goT the caliper rebuild kits from Mark Gray during the week. And able to finish the fettle of the calipers. The rear ones had been resleeved in stainless, the sleeves left a sharp edge which I think had nicked the old seals on there. So after looking at it a while I found two lengths of copper pipe. The larger one was just a little too large but after I used a pipe cutter on it the opening closed up nicely. I cleaned up the inside and the edge of the pipe with some sotchbrite pad and lubed it with some brake fluid. I fitted the new piston with seal into the pipe, aligned it with the cylinder and used the smaller pipe to pop the piston into place. Worked a treat and no nicked seal this time!


All the parts are rebuilt and ready to go in.


I fitted the calipers up front and the servos. While doing the front calipers I noticed the discs were in a bad way, horribly grooved on the insides. So I thought, easy ill use the hubs and discs from my old car. Cleaned the bearings in kerosene and replaced with fresh grease. Fitted the hub on the left side and put the bearing cap on. That doesn't look right! So, I guess normal P6's and Rostyle P6's have different hubs, who knew? Not me that's for sure..so I pulled it, took it and the old hub down to the basement workbench and swapped those over. All good now. But here's the difference for everyone.


Anyways, all fitted now up front. I've lifted up the balk end in readiness for swapping the diff, DeDion tube arms and brakes over. I have to pack everything back into the garage at the end of each day so it's a bit tight before I close the door.
 

Attachments

sdibbers

Well-Known Member
#11
So, I have to do a sort of spare parts Tetris to get every thing back into the garage after working. This pic was from yesterday. Now the back is about 18" higher with more stuff below it.


Here's the front caliper in place and the servos too.
 

Attachments

sdibbers

Well-Known Member
#12
Sorry about the pics all being rather large. The perils of using an iPad for updating I guess.

Turns out that I have 5.5" rostyles not 5" and being a 69 year model it has the 3500 hubs and rear top links. I had ordered 165r14 Vredesteins for the car, but have decided to swap them for 185r14s seeing as the car can take them. The website I used were great and offer free return shipping. Found out after checking the tyres on the car that I have 165s up front and 175 on the rear near side and 185 on the offside. So, with that and the age of the tyres I'm doubly glad I planned on replacing them.
 

sdibbers

Well-Known Member
#13
Dramatic music goes: Dum Dum Duuuhm!

Well, found this while dropping the back end yesterday.


Structurally it seems to be holding up fine. I had used the steel bar in the jacking tube to hold the car up while working under there, there's no sign of movement in the area. Having said that my heart sunk when I spotted it. Its the only area I'm aware of rust on the car other than the boot floor. I was expecting to deal with the boot floor this winter. I know this can be a fairly 'interesting' area to repair with the D post, sill end and underbody all joining together. I've been looking over the rest of the car to make sure I haven't missed other areas, so far all else looks good. Any pointers will be very gratefully received


I guess the undercoat was damaged at some time by a careless garage in the past. I feel like I can make the repair panels easily enough, however welding here would be fool hardy. The garage is pretty tight and although I have very understanding neighbours here, I feel like I would be pushing my luck. I'm searching for a reliable welder/resto company in the area now. I have a friend in the auto business here and he's thinking about it too. To be honest it could be a lot worse, but I i'm glad I found it now rather than later. Looking at things I think I will need to remove about 12" (304mm for those watching in Colour) forward of where the read flange should be and looking inside about 3-4" above (75-100mm). Fingers crossed.

Meanwhile, I have dropped the trailing arms, springs, propshaft and final drive extension crossmember. I think I should be ready to drop the final drive and dedion tube from the car tomorrow morning before work. I normally get about 45 mins a morning to play before jumping in the shower and going to work. So with luck I might even have a road worthy car by the end of the week if I can convince the Missus or my stepson to pump the brake pedal while I swear at bleed nipples.
 

Attachments

Demetris

Well-Known Member
#14
Re: Dramatic music goes: Dum Dum Duuuhm!

sdibbers said:
Well, found this while dropping the back end yesterday.
You don't need to worry too much about it.
My TC also had some rust in the same area (and in the boot floor too!), although not as much as yours. As this is a (what else!) boxed area, it somehow collects water and rusts from inside out. In my car it was only the bottom flat part of this box on the the left side of the car that was missing, so after 7,5 years of ownership it is only a month ago that i repaired it. On the right side the bottom part is still there, just a little weak from rust.
Just take care when you weld it to remove the rear seat and sound insulation because this box section borders with another inside the car with lots of "hairy stuff" in there.
Also you need to find out what caused the water to collect in there in the first place. I suspect various deteriorated rubbers in the boot opening and fuel filler area.
Other than that, it looks like an excellent car!
 

sdibbers

Well-Known Member
#15
Demetris, thanks for the advice! I'll look at the area above with the wing off at a later date. I need to find a place that I can weld in, along with a welder to rent. The only places I can rent a decent mig from are very expensive here, so I might start trawling Craigslist for good used one. Then it's just a question of finding a suitable space. My garage is just too small for me to safely weld in. And we have too many kids playing in my street to feel good about doing it on the drive. The neighbors here are very nice and I don't want to push my luck with them.

Next time we buy a house with a two car garage!
 

sdibbers

Well-Known Member
#16
Yesterday marked a turn in the tide. I removed the last item from the back end. In this case the final drive/brakes/DeDion tube assembly. In the process I found that the nose mount had separated from it metal tube (used a spare I had laying around) and one of the bushes for the top link was in a similar state.

On the top link I used some 3M windo-weld eurothane rubber to repair the bush until I can find a 3500 one to replace it. I've read good things about this stuff and decided it was worth a try.

Rebuilt calipers were fitted to my cleaned up final drive.

And with the help of Matthew, my step son (what a great guy!) we were able to fit the new final drive into place along with a new handbrake cable.

I just need to fit the Dion tube, drive shafts, trailing arms, top links and springs. Bleed the brakes and Beryl should be road worthy for the first time in three years!
 

Attachments

sdibbers

Well-Known Member
#18
Good spot Harvey! Actually I removed it from the old diff extension to reuse the rubber pads. The new one (from my old car, confused yet?) rubbers were soft from blown seal in its past. I have replaced the seal and used the good rubber nubs on the new diff extension.
 

harveyp6

Well-Known Member
#19
sdibbers said:
Good spot Harvey! Actually I removed it from the old diff extension to reuse the rubber pads.
IIRC the WM says you're not supposed to remove them presumably because you'll get vibrations afterwards, but I've never had problems and it's pretty difficult to get them back incorrectly because of the bosses on the housing and the rubbers. I just can't help noticing these things....
 

sdibbers

Well-Known Member
#20
To be clear, I have the damper on the clean diff now fitted to car now. I did wonder if they really made that much of a difference.
 
Top