Rover 2000TC HS6 SU carburettor overhaul

#22
Will get some tissue one all the joints tomorrow. I haven't used sealant on any gaskets, I just dry fitted. Do you think that could be the problem.
Regards Terry H
 
#24
When the carbs were off there was still another part that had a joint before going into the engine. Haven't seen that on a car before. If you look at the inlet manifold there are metal brackets between the manifold and the carbs where the butterflies are. and they did appear to be loose but I couldn't tighten them up so I assumed they were some sort of vibration related item. Regards Terry H
WP_20200227_15_42_18_Pro.jpg WP_20200227_15_42_18_Pro.jpg
 
#26
Update. I am 95% positive the high revs are due to the "Carb Adaptor Assembly" O ring not seating correctly. It seems as if the carbs are a loose fit to the inlet manifold and held in place by the large spring and bracket that runs between both carbs, the 4 studs on each carb attach them to the adaptor plate not the manifold. There is quite a bit of movement at the point where the assembly meets the inlet manifold. I started the engine, revs running high I lifted the carbs and the revs dropped, then let go and revs rose again so lifted and wiggled up and down and the revs dropped and stayed down. I now have it running of sorts but will be looking for a supplier of this O ring. Have checked Wadhams but they don't have them listed. Anyone know where to get these before I do a internet search. I don't know where to start with this one as it's not a carburettor part, more of a Rover adaption.
Regards
 

Demetris

Well-Known Member
#29
I hope that the grease you have used is some kind of "rubber grease", because the common grease destroys most types of rubber.
 
#30
I have a tin of red rubber grease I'm going to use when I find it. It's the same stuff I used on the brake caliper seals on my Scimitar when I refurbished those. Recommended for rubber.
Regards Terry H
 
Top