Right angle drive for strip speedometer

#1
I have a grinding rotational noise coming from behind my speedometer.
I took a look at my boxes of spares and found a Smiths box with an angle drive in it. Part number BG2410/00A
Ebay has this BG2410/00A (item number 280619240765) but the box with it says "gearbox".
Will the one I have work behind the speedo, or is this the one specifically for the other end of the cable at the gearbox?
Roy
 

Pilkie

Active Member
#3
The one on ebay is for the speedo.
2000/2200 manuals,IIRC dont have an angle drive on the gearbox only the auto's do,and I think they are all the same for 2000/2200/3500.
I have a feeling all speedo end angle drives are the same,but might be wrong??
i think when it says gear box its describing the item itself.
 
#4
As I found out (the hard way) - the right angle drive for the gearbox is larger than the one for the back of the speedo. I'm not sure about the manuals not needing one on the gearbox, as I haven't needed to change one on my manuals (not yet at least). But for sure the auto's have 2.


Cheers, Adam.
 
#6
Thanks guys.
The one pictured on Ebay is the type I have.
I was thinking the manuals don't have a drive at the gearbox, but thought I would access the knowledge of the forum before removing carpets to check.
I had my speedo out last year to replace the lights and light rheostat, but didn't recall seeing the tab at the end that attaches to the speedo.
Looking at a diiferent Ebay auction for a 3500 angle drive, the tab faces the opposite direction, otherwise looks just the same.
Will replace soon. Hopefully to resolve the noise otherwise the speedo might need some attention.
 
#7
I occasionally have this occurence with Bruiser & it's very loud. The red strip also bounces up & down when it happens though it mostly seems confined to quite cold days....odd! :?: I changed the drive for POE's one, but it didn't cure the problem so I assume it's the speedo itself.
I haven't changed it as yet because it hasn't happened for some time & summer's now on the way.
 
#8
If you're going to have the angle drive off, then a definite opportunity to withdraw the speedo cable inner and lubricate it. As others have recently posted, soak all bar the top couple of inches in light oil, wipe clean and then insert. Repeat a few times to make sure the lubricant gets all the way down to the gearbox end. Leave the speedo end free of oil to make sure you don't get any migrate up into the angle drive.

Chris
 
#9
Chris, to lubricate the cable, I just withdraw it from the speedo end then?
Are there any clips, etc, holding the inner cable in place?
I don't have to remove the gear box side, and then reinsert when oiled?
Roy
 
#10
It just pulls straight out once you have detached the cable from the angle drive. Re-engaging at the gearbox end should be just a case of rotating the inner whilst pushing gently - but you can always have the gearbox end off separately to verify it has engaged.

Chris
 

harveyp6

Well-Known Member
#11
cdnp6 said:
I was thinking the manuals don't have a drive at the gearbox, but thought I would access the knowledge of the forum before removing carpets to check.
Correct. Only autos have gearbox angle drives.
 
#12
Today saw the dash cover off and the speedo cable lubricated before I replaced my angle drive with a new one.

As soon as I pulled the speedo forward, I saw the current angle drive was different than the correct one.
The one I took off the back is a BG2410/10, with the tab in the wrong direction which does not connect with the post on
the back of the speedo, and has an extension that my replacement does not.

I replaced the drive with my new one and now see why the other was there.
With the speedo fastened in its correct spot, the end of the angle drive does not clear the edge of the hole in the underside of the dash,
and the cable cannot be tightened.

Is there any difference in gearing betwen the correct BG2410/00 and the BG2410/10 that was in place?
Whats my best course of action here now, find a new 2410/10 and use the tab from the 2410/00 or keep fiddling and try to get the 2410/00 to work
 

Attachments

harveyp6

Well-Known Member
#13
I don't think there is any gearing on the drives, they are 1:1 and are just used to move the drive through 90 degrees. It looks like you could just turn the bracket that locates on the pin by 180 degrees to get it the same as your old one, but that won't get you out of the problem of getting the cable to fit.
 

Demetris

Well-Known Member
#14
The one in the first photo is the same with the one that my car has.
When i am trying to connect the cable, i always have the whole speedo loose (i.e. i have not fitted at all the two retaining screws) in order to help a little with the cable-angle drive alignment. It seems from the photo that if you can pull the speedo a little towards the back of the car, it will be easier to connect the cable.

Also it seems as though you can move the extension from the old angle drive to the new one.
 
#15
Shouldn'ta had all those wobbly pops with friends last night...
Going back out to the car I did what I should have done in the first place... Attached the cable to the angle drive first, then to the speedo back, secure speedo... Done!
15 minutes start to finish... when I smartened up.
Road tested and the noise is now gone.
 

jp928

Active Member
#16
Looking into this now - erratic speedo , much hunting at low speeds. The wsm is in a loop again - the section for removing instruments (88.?) says remove the dash cap (76.?), which says remove the instruments....whats a practical sequence here please. Have a new cable on hand.
 
Top