Oil pressure guage on 3500 not working .

#1
I have asked three/ four garages to rectify this fault , but all seem to shy away from it (can you believe one mechanic even suggested that as it was such a 'tough' engine that it was not essential to have the gauge working)!!!.. would someone mind explaining the basic mechanics of the set up , so that I can delve into it myself.. Is it a system combining mechanical /electrical ? what would be the most likely faults etc , and of course if there were any fault finding checks that I could carry out , that would be great .
Thanks folks ..
 

Cafcpete

Active Member
#2
It's a 'simple' electrical circuit. To check if the gauge is working short out the wire at the sender. It should go to maximum if the wire/gauge are working. If it does then it's the sender, if it doesn't then look at the cable to the gauge or replace the sender.
 
#4
Wow, that's a great start.. that's my weekend job sorted , BUT ,please forgive my ignorance ,where is the sender unit located … thanks for such a super quick reply ..
Regards Pat Pearce (Mr Masala )

 

Cafcpete

Active Member
#5
I’m guessing V8? Looking from the front it’s on the left hand side near the front. It’s quite a large item with one wire connector. Someone will be along with a better description :)
 
#6
I’m guessing V8? Looking from the front it’s on the left hand side near the front. It’s quite a large item with one wire connector. Someone will be along with a better description :)
Yes V8 it is .. that's a super bit of info for me .. thank you so much .. will inform you of the results of your super info and my 'super-human' efforts very soon .. again . thank you
 

iwish

Active Member
#8
Hi Guys,
I don't know if i am wrong about this, on my car (Series 2 3500S) the pressure gauge sender and and light indicator sender are fitted in reverse of this. The small light switch is nearest to the filter. Does it make any difference?
 

Barten

Active Member
#10
I have just fixed my oil pressure. We traced the fault to be in the printed circuit in the instrument. I had a spare one, so I swapped over all the gauges. I could also have fixed it by putting a wire between the points where the printed circuit have failed.
 
Top