New member

Dgu

New Member
#1
Hi all,
I have a problem with my rover 2000 SC 64. Years ago, I disassembled the wiper washer and the switch. Could someone help me with some photos or schemes? I don't know how I can fix it.
Thanks to everyone for the answers,
Regards, 20170520_192353.jpg
 

Ban306

Active Member
#4
That is a realy nice series one you have there DGU amazing condition the bumper is really nice and the interior is a delight.
Can you post the photos of what your trying to put back together its better than the other way round. your photos are perfect no need to make smaller.
 

Dgu

New Member
#5
That is a realy nice series one you have there DGU amazing condition the bumper is really nice and the interior is a delight.
Can you post the photos of what your trying to put back together its better than the other way round. your photos are perfect no need to make smaller.
Hello, Ban306, first of all, sorry for answering later.I have three pieces which I don't know how connect them.
First, I don't know if that scheme is of my P6.
 

Attachments

chrisw

Well-Known Member
#11
The difference is because you have an early car - am guessing that your chassis number ends with a letter B?

I'll try and dig out the 1964 workshop manual. Might be able to check the wiring on the 64 car I'm currently stripping.
 

chrisw

Well-Known Member
#17
Yep, best to post in the technical section.

Phil - should be a sharkstooth. Does yours have a delay switch fitted? Fairly sure mine is on/off only.. Can't remember as it's off in storage.
 

Phil Robson

Well-Known Member
#19
Does yours have a delay switch fitted? Fairly sure mine is on/off only.. Can't remember as it's off in storage.
I think it does Chris - although it’s never worked. Hoping to bring mine to its home garage tomorrow (can swap with Hazel on the way back from the shops :)) so I’ll check.

I’m intending to start preparing the bonnet for painting - I’ve only been driving it for 5 years like it is....:rolleyes:
 

roverp480

Active Member
#20
I don't think the 1964 vehicles would have had a wiper delay . Isn't it only fitted to wipers with rod linkage rather than the older rack system?
 
Top