Fuel pump feed.

#1
I will be fitting a huco pump in the engine bay in the next few days, in preparation for fitting i have been doing a bit of wiring work.

I now have a ignition feed connected up ready to fit the pump, but have now realized that the feed i intend using is also powering the radio.

Question is if i use this feed will it affect the radio with regard interference when the pump is running? dont want to fit it all up and find i have a constant ticking on the radio.

Regards Steve.
 
#3
jp thanks for the reply and advice. I think I will use the washer as you suggest, the way it is connected at present the pump would run with ign on and in the aux position ( not good i think).

Regards Steve.
 

jp928

Well-Known Member
#4
My pump doesnt run on accessory- my reading of circuit is that washer pump and coil are both powered from same point, so either on accessory sounds wrong.
 

colnerov

Well-Known Member
#5
Hi, To my mind the coil and the fuel pump should have an unfused ignition supply. Taking it from the washer pump means it's at the mercy of a fault in one of the other items from that fuse. You then not only come to a grinding halt but you have fault find all the other items and correct it. Because it will happen when most inconvenient and probably pissing down with rain!! If you're worried about the possible dangers in the event of an accident then wire it through an inertia switch and its own fuse, that way you only have one place to check. By the way mount the inertia switch on a solid part of the car and not the slam panel, that way it gets tripped in an accident and not when you shut the bonnet a bit too vigorously.

Colin
 

quattro

Administrator
Staff member
#6
I agree with Colin. I have had a short in the wires to the reverse light switch recently and it blew the fuse which left me with no gauges, brake lights, reverse lights or indicators. It would have left you with no fuel pump either.
 

jp928

Well-Known Member
#7
I hear what Colin is saying.... As I read the diagram, the coil is fed off the input side of F19-20, while the washer pump is fed off the output side, as are the warning lights, tacho. FWIW I have my inertia switch mounted below and a bit rearward of the coil, so I think its OK. Is there an issue with feeding the pump from the coil input?
 

colnerov

Well-Known Member
#8
Hi, The coil has a ballasted supply of 8 or 9 volts, is that enough for the pump to work properly or at all? If you run an extra wire direct from the ignition switch it can be used for the fuel pump and the module for the electronic ignition if fitted.

Colin
 
Top