...and suddenly the throttle jammed open! What the *#§%!?

mrtask

Well-Known Member
#1
Never a dull moment when you drive an old car, eh? This morning I was cruising up a steep hill at 20mph in 3rd. Traffic just in front of me had stopped for a red light, I was about to come to a halt and preselect first. All of a sudden as I dipped the clutch the engine revs raced madly. I made certain my right foot was only on the brake but not on the gas. The gas pedal wasn't obstructed by anything. Revs stayed up at a noisy 3000 or so rpm.
Pulled into a handy adjacent parking bay, cut the engine, popped the hood. No linkages had come apart. Started it up, engine immediately revving at over 3000! Pressed the throttle linkages closed with my fingers, the revs dropped. Few blips with the little lever on the intake manifold, settled back to normal idle.
I'm completely baffled. A close inspection when I got back home hasn't revealed anything visibly wrong.
It did happen on what really is a particularly steep slope, but I can't see how that could cause the engine speed to suddenly rise and stick!?!?!?
 

harveyp6

Well-Known Member
#2
If you can press the linkage closed and the revs drop back to normal then it is a linkage problem, systematically separate the linkage until you find the cause.

I had a throttle return spring snap coming up to a line of stationary traffic in a loaded tow truck and although the revs did drop they did so slowly that it was a heart in mouth feeling for a good few seconds.
 

mrtask

Well-Known Member
#4
Thanks for the suggestions.
There is nothing obstructing the gas pedal.
Went for a drive this morning, didn't get far before I noticed that on stopping the revs were not returning to proper idle, but over-revving. Not as high as yesterday, but not right. 1500rpm, not the desired 650 or so.
Popped the hood with the engine still (over-)running, linkages all back to their 'at rest' positions. I have to directly press the RH throttle fully closed for it to return to idle. It is as if the LH carb has closed, but the RH is ever-so-slightly jammed open.
Hard to see what is going on with the linkages tucked behind the carbs, but easier without a standard air filter box getting in the way.
Maybe (probably!) I'm barking up completely the wrong tree, but on the LH carb the throttle return spring has a long 'finger' that tucks neatly into a little two-pronged retainer. See photo:

LH-throttle-return-spring.jpg

But on the RH carb the 'finger' of the throttle return spring (1) doesn't seem to reach the corresponding retainer. Rather, it is pointing at a 4-o-clock angle, and interfering with the adjacent choke mechanism. Shouldn't it be pointing at more like a 5-o-clock angle, and the end held away from the choke underneath that little two-pronged retainer (2) ? See explanatory photo:

RH-throttle-return-spring.jpg
If I press the finger of the spring down, the throttle closes properly and the idle returns to where it is supposed to be. Of course, it just springs back up again when I let go. In the photo above I've pulled the end of the finger of the throttle return spring in front of the choke mechanism. After a few blips of the throttle it ends up at the same angle but behind the choke mechanism, where I think it is getting hung up on the choke return spring. Preventing that throttle to close fully.
Or does that all look correct, and am I clutching at imaginary straws!?!?!?
Forgive my lack of proper terminology. D'ya see what I mean though?
 

quattro

Administrator
Staff member
#5
Have you had a good looksie in the area under that mechanism, for perhaps the end of the spring that broke off? Just a thought :hmm:
 

mrtask

Well-Known Member
#7
I just found a photo of the RH carb from whilst it was away being refurbished, and it clearly shows the finger of the throttle return spring should in fact be longer, and has indeed snapped orf. Damn and blast.

RH-carb-after-ultrasonic-cleaning-02.jpg
 
Last edited:

mrtask

Well-Known Member
#9
As a temporary repair, extend the spring with some small dia. tube
Good thinking. I had been envisaging faffing about using a nail and some small zip ties. :rolleyes: :hmm: Why I didn't twig that a bit of small diameter tube would be a lot easier, I don't know.
I suppose removing the broken one and fitting a replacement will entail having to remove the carb again. :mad:
 
#10
MrT,
The same thing happened to me years ago whilst waiting at traffic lights in my Morris Marina. Luckily, I was taught to always put the gearstick in neutral and apply the handbrake when at lights. The engine made a hell of a racket before I sheepishly pushed it into a parking bay.
I replaced the broken spring and remember adding a second ‘insurance’ spring to the carb lever and anchoring the other end somewhere on the engine just in case it ever happened again.
I recall the additional spring gave a significant improvement to the feel of the accelerator pedal.
 
Top